nixhome/zsh.nix

15 lines
481 B
Nix

{ config, pkgs, ... }:
{
home.shellAliases = {
idot = "dot -Tpng -Gbgcolor=#232627 -Ncolor=white -Nfontcolor=white -Npencolor=white -Ecolor=white -Efontcolor=white -Epencolor=white -Npenwidth=2 -Epenwidth=2 -Nfontname=\"Courier bold\" -Efontname=\"Courier bold\" | timg -";
};
programs.zsh = {
enable = true;
autosuggestion.enable = false;
enableCompletion = true;
enableVteIntegration = true;
initExtra = (builtins.readFile ./rcfiles/zshrc);
};
}